Testen von Dokumentdefinitionen

Vor der Masseneingabe von Dokumenten müssen die Dokumentdefinitionen getestet werden. Beim Testen werden Dokumente zu Teststapeln hinzugefügt, da für diese Stapel die lokale Version der Dokumentdefinition verwendet wird. Diese Stapel sind im Hauptfenster des Programms über Ansicht → Teststapel verfügbar. Sie können auf die Teststapel auch vom Fenster des Dokumentdefinitionseditors aus zugreifen, indem Sie Stapel → Zu Teststapel wechseln....

Wichtig! Ein Teststapel kann nur von demjenigen Benutzer verwendet werden, der ihn erstellt hat. Gegebenenfalls kann ein Arbeitsstapel als Teststapel verwendet werden. Er dient dann als Bildquelle für den Teststapel.

Eine Dokumentdefinition kann direkt im Dokumentdefinitionseditor mit dem Bild getestet werden, das zum Erstellen der Dokumentdefinition verwendet wurde. Wählen Sie zum Starten des Tests Testen → Test ausführen. Wie bei einer Dokumentverarbeitung wird das Datenformular angezeigt und es werden Formatfehler, nicht eindeutige Zeichen und Regelfehler ausgegeben.

Sie können das Menü Testen → Ansicht verwenden, um die Anordnung der Fenster zu verändern, und das Menü Testen → Überprüfung, um die einzelnen Elemente der Überprüfung, nicht eindeutige Zeichen und Regelfehler durchzugehen. Klicken Sie auf die Schaltfläche Schließen, oder wählen Sie Testen → Test beenden, um den Test zu beenden.

Wichtig! Im Testmodus führt eine Veränderung der Feldränder nicht dazu, dass das Programm das Feld erneut erkennt. Im Gegensatz dazu ist dies bei einer Änderung der Feldränder im Dokumentfenster der Fall.

Um Ihre Dokumentdefinition mit anderen Bildern zu testen, wählen Sie einen Teststapel aus (Sie können dies tun, indem Sie im Dokumentdefinitionseditor Stapel → Zu Teststapel wechseln... wählen). Bevor das Dialogfeld zur Stapelauswahl angezeigt wird, prüft das Programm die aktuelle Dokumentdefinition auf Fehler. Wenn die Dokumentdefinition fehlerfrei ist, wird sie gespeichert und das Dialogfeld zur Stapelauswahl wird angezeigt. Wenn Sie in diesem Dialogfeld einen Stapel auswählen, wird das Programmfenster aktiviert und wechselt automatisch zum neu gewählten Stapel.

Hinweis. Bei Bedarf können Dokumente zwischen Stapeln kopiert oder verschoben werden. Bei diesen Vorgängen werden alle Informationen über das Dokument wie z. B. die zugeordnete Dokumentdefinition und erkannte Daten beibehalten. Um Dokumente zu kopieren oder zu verschieben (z. B. von einem Arbeits- zu einem Teststapel für Debuggingzwecke), wählen Sie diese beim Anzeigen des Stapelinhalts aus der Liste, drücken Sie Strg+C (zum Kopieren) oder Strg+X (zum Verschieben), klicken Sie auf die Schaltfläche   oder in der Symbolleiste oder wahlweise auf das Element Kopieren oder Ausschneiden im Menüpunkt Bearbeiten. Öffnen Sie dann den Stapel, in den die Dokumente kopiert oder verschoben werden sollen, und drücken Sie Strg+V oder klicken Sie auf die Schaltfläche in der Symbolleiste oder auf das Element Bearbeiten → Einfügen im Hauptmenü.

Es wird empfohlen, jede Dokumentdefinition mit mindestens 20 Dokumentbildern zu überprüfen (wenn Dokumente von Hand ausgefüllt werden, empfiehlt es sich, Dokumente mit verschiedenen Handschriften zu testen).

Beim Testen muss Folgendes überprüft werden:

  1. Ist eine ausreichende Anzahl markierter Anker und Kennungen für die zielgerichtete Anwendung einer Dokumentdefinition auf ein Bild vorhanden.
  2. Wurden die Feldeigenschaften korrekt konfiguriert.
  3. Wurden die Regeln korrekt konfiguriert.
  4. Wurde der Export korrekt konfiguriert.

Beim Testen müssen Sie die gesamten Vorgänge durchführen, die beim Verarbeiten von Dokumenten anfallen.

Wenn beim Testen Regelfehler, falsche Feldwerte o. Ä. erkannt werden, müssen Sie die Dokumentdefinition bearbeiten, um die Fehler zu korrigieren.

Sie können die Dokumentdefinition erst nach Beheben aller Fehler veröffentlichen und dann mit der Masseneingabe von Dokumenten beginnen.

Siehe auch:

Arbeiten mit einem konfigurierten Projekt

1/14/2021 2:17:18 PM


Please leave your feedback about this article