Test de définitions de documents

Avant de commencer à entrer un gros volume de documents, vous devez tester les définitions de documents. Les tests sont effectués à l'aide de documents ajoutés aux lots de test, puisque ces lots fonctionnent avec la version locale de la définition de document. Ces lots sont disponibles dans le menu Affichage → Lots de test de la fenêtre principale du programme. Vous pouvez également accéder aux lots de test à partir de la fenêtre de l’éditeur de définitions de documents, en sélectionnant Lot  → Basculer vers le lot de test....

Important !Seul l'utilisateur ayant créé le lot de test est autorisé à l'utiliser. Si nécessaire, vous pouvez utiliser un lot de travail comme lot de test, auquel cas il fera office de source d'images pour le lot de test.

Vous pouvez tester une définition de document directement dans l’éditeur de définitions de documents à partir de l’image utilisée pour la créer. Pour commencer le test, sélectionnez Test  → Exécuter le test. Un formulaire de données identique à celui utilisé dans le cadre du traitement de documents s’affiche et les erreurs de format, les caractères incertains et les erreurs de règles apparaissent.

Vous pouvez réorganiser les fenêtres depuis le menu Test  → Affichage et parcourir les éléments vérifiés, les caractères incertains et les erreurs de règles depuis le menu  TestingVerification. Cliquez sur le bouton  Fermer ou sélectionnez Test → Terminer le test pour interrompre le test.

Important !En mode test, si la bordure d’un champ est modifiée, le programme ne devrait pas à nouveau reconnaître le champ étant donné que vous modifiez les bordures de champs dans la fenêtre du document.

Pour tester votre définition de document sur d'autres images, sélectionnez un lot de test (pour ce faire, vous pouvez sélectionner Lot → Basculer vers le lot de test... dans l'éditeur de définitions de documents). Le programme vérifie que la définition de document en cours ne comporte pas d’erreur avant d’afficher la boîte de dialogue de sélection du lot. Si la définition de document ne comporte aucune erreur, elle est enregistrée et la boîte de dialogue de sélection du lot s’affiche. Lorsque vous sélectionnez un lot de cette boîte de dialogue, la fenêtre principale du programme s’active et bascule automatiquement vers le lot nouvellement sélectionné.

Remarque :Si nécessaire, les documents peuvent être copiés ou déplacés entre les lots. Pendant ces opérations, toutes les informations sur le document, comme la Définition de document associée et les données reconnues, sont préservées. Pour copier ou déplacer des documents (p. ex. : d'un lot de travail à un lot de test pour débogage), sélectionnez-les dans la liste lorsque le lot est affiché, puis appuyez sur Ctrl+C (pour copier) ou Ctrl+X (pour déplacer), cliquez sur   ou sur le bouton de la barre d'outils ou utilisez Copier ou Couper dans le menu Édition. Ouvrez ensuite le lot vers lequel vous souhaitez copier ou déplacer les documents et appuyez sur Ctrl+V. Sinon, vous pouvez aussi cliquer sur le bouton de la barre d'outils ou sélectionner l'option Édition → Coller du menu principal.

Nous recommandons de tester chaque définition de document avec au moins 20 images de documents (si les documents sont remplis à la main, il est préférable d'utiliser des documents remplis par des personnes différentes).

Il est nécessaire d'effectuer des tests afin de déterminer :

  1. S'il y a suffisamment d'ancres et d'identificateurs marqués pour l'application d'une définition de document donnée à une image.
  2. Si les propriétés des champs ont été correctement configurées.
  3. Si les règles ont été correctement configurées.
  4. S'ilexportation has been configured correctly.

Pendant le test, vous devez effectuer l'ensemble des opérations effectuées lors du traitement de documents.

Si des erreurs de règle, des valeurs de champ incorrectes, etc. sont détectées pendant le test, vous devez modifier la définition de document afin de les corriger.

Ce n'est qu'après avoir éliminé tous les problèmes détectés que vous pouvez publier la définition de document et commencer à entrer un gros volume de documents.

Consultez également :

Utilisation d'un projet configuré

4/13/2021 11:12:29 AM


Please leave your feedback about this article