Testing Document Definitions

Before starting mass document input, Document Definitions must be tested. Testing is undertaken using documents added to test batches, since these batches work with the local Document Definition version. These batches are available from the View → Test Batches menu of the main program window. You can also access test batches from the Document Definition editor window by selecting Batch → Switch to Test Batch....

Important! Only the user who created a test batch can work with that test batch. If required, a working batch can be used as a test batch, in which case it will serve as a source of images for the test batch.

A Document Definition can be tested directly in the Document Definition editor, on the image that is being used to create the Document Definition. To start the test, select Testing → Run Test. The data form will be displayed as in the case of document processing, and format errors, uncertain characters, and rule errors will be displayed.

You can use the Testing → View menu to rearrange the windows and the Testing → Verification menu to navigate the verification items, uncertain characters, and rule errors. Click the Close button or select Testing → Finish Test to stop the testing.

Important! In testing mode, changing a field border will not cause the program to recognize the field anew, as is the case when you change field borders in the document window.

To test your Document Definition on other images, select a test batch (you can do this by selecting Batch → Switch to Test Batch... in the Document Definition editor). Before the batch selection dialog box is displayed, the program checks the current Document Definition for errors. If the Document Definition is error free, it is saved and the batch selection dialog box is displayed. When you select a batch in this dialog box, the main program window will become active and automatically switch to the newly selected batch.

Note: If necessary, documents can be copied or moved between batches. During these operations, all information about the document, such as the matched Document Definition and recognized data, is preserved. To copy or move documents (e.g. from a working batch to a test one for debugging purposes), select them in the list when viewing the contents of the batch, then press Ctrl+C (to copy) or Ctrl+X (to move), click or button on the toolbar or use the Copy or Cut item of the Edit menu. Next, open the batch where you want to copy or move documents and press Ctrl+V, click button on the toolbar or select the Edit → Paste item in the main menu.

We recommend checking each Document Definition with at least 20 document images (if documents are completed by hand, it is preferable to use documents completed by different people).

Testing is required to determine whether:

  1. There is a sufficient number of marked anchors and identifiers for certain application of a Document Definition to an image.
  2. The field properties have been configured correctly.
  3. The rules have been configured correctly.
  4. Export has been configured correctly.

During testing, you need to perform the entire sequence of actions performed when processing documents.

If rule errors, incorrect field values, etc. were detected during testing, you must edit the Document Definition to correct them.

Only after elimination of all of the problems detected can you publish the Document Definition and begin mass input of documents.

See also:

Operating a configured project

01.12.2020 7:03:59


Please leave your feedback about this article