Document batches

Documents to be processed are put into batches. The principles of grouping documents into batches are determined by the user. For example, the user may choose to process all documents as one batch, or group together documents imported on the same day or scanned at one go.

On the Processing Stations, batches are created automatically when importing images from Hot Folders. On Scanning Stations, batches can be created manually by operators or automatically (if the appropriate scanning profiles are available).

When a batch is created, its type should be specified, which defines how the batch is to be processed.

Page images are added during processing. See Adding page images for details.

On the Project Setup Station, Document Definitions can be debugged by creating batches, adding document images into the created batches, and processing them (i.e. recognizing, verifying, and exporting the results). To create a new batch, right-click the batch list in the main window and select New Batch... from the shortcut menu.

Working and test batches

Test batches are used by the Batch Setup Operator to test and debug Document Definitions. Working batches are intended for processing documents with ABBYY FlexiCapture. The Batch Setup Operator can also access working batches if errors occur during processing. In the event of an error, the operator can open the respective working batch and correct the error. Test batches and working batches are different in that the local Document Definition is used to process the documents in a test batch, whereas a published Document Definition is used to process the documents in a working batch. See Editing and publishing a Document Definition for details.

To open the list of batches, select the Working Batches or Test Batches item from the View menu on the Project Setup Station.

Note: If necessary, documents can be copied or moved between batches. All the document information, including the matched Document Definition and recognized data, will be preserved. To copy or move documents (e.g. from a working batch to a test batch for debugging purposes), select them in the list and press Ctrl+C (to copy) or Ctrl+X (to move), or click (to copy) or (to move) on the toolbar, or click  Copy or Cut on the Edit menu. Next, open the batch into which you want to copy or move the documents and press Ctrl+V, or click on the toolbar, or click Paste on the Edit menu.

Note: You can also make copies of documents inside any batch. To create a copy of one or several documents in a batch, select them and then click Tools Duplicate Documents on the main menu. Each copy created this way will be placed immediately after the source document in the document list. A copy will be given a new identifier, while all the document information, including the matched Document Definition and recognized data, will be preserved.

12/1/2020 7:03:59 AM


Please leave your feedback about this article