文書定義のテスト

大量の文書のインプットを開始する前に、文書定義をテストしなければなりません。テストは、テストバッチに追加された文書を使用して行なわれますが、これはそのバッチがローカル文書定義バージョンで動作するためです。これらのバッチは、メインプログラムウィンドウの 表示→ テストバッチ メニューから利用できます。また、テストバッチには文書定義エディタからも、 バッチ → テストバッチに切り替え... を選択することでアクセスできます。

重要! テストバッチを作成したユーザーだけが、そのテストバッチを使えます。必要であれば、動作中のバッチをテストバッチとして使用できますが、その場合これはテストバッチの画像のソースとなります。

文書定義は、文書定義を作成するために使用されている画像について、文書定義エディタで直接テストできます。テストを開始するには、 テスト → テストを実行 を選択します。データフォームは文書処理中に表示され、フォーマットエラー、不確定な文字、ルールエラーが表示されます。

ウィンドウを再配列するには、 テスト → 表示 メニューを使用することができ、アイテム検証、不確定の文字、ルールエラーへと進むには、 テスト → 検証 メニューを使用することができます。テストを中止するには、 閉じる ボタンをクリックするか、 テスト → テストを完了 を選択します。

重要! テストモードでフィールドボーダーを変更しても、それは文書ウィンドウ内でフィールドボーダーを変更したのと同じで、プログラムはそれを新しいフィールドと認識しません。

他の画像で文書定義をテストするには、テストバッチを選択します (そのためには、文書定義エディタで バッチ → テストバッチに切り替え... を選択します)。バッチ選択ダイアログボックスが表示される前に、プログラムは現在の文書定義のエラーをチェックします。文書定義にエラーがない場合、これは保存され、バッチ選択ダイアログボックスが表示されます。このダイアログボックスでバッチを選択すると、メインプログラムウィンドウはアクティブとなり、新しく選択されたバッチへ自動的に切り替わります。

注: 必要に応じて、文書をバッチ間でコピーまたは移動することができます。これらの操作の間、一致した文書定義や認識されたデータなど、文書に関するすべての情報は保存されます。文書をコピーまたは移動するには、バッチの内容を表示するときにリストから選択し、 Ctrl+C (コピー)または Ctrl + X (移動)、 または ボタンをツールバーでクリックするか、 コピー または 切り取り 項目を 編集 メニュー。次に、文章をコピーまたは移動するバッチを開き、 Ctrl+V を押すか、 ボタンをツールバーでクリックするか、 編集→貼り付け 項目をメインメニューで選択します。

それぞれの文書定義で、少なくとも20の文書画像をチェックすることを推奨します (文書が手書きで作成されている場合、異なる人が作成した文書を使用することが望ましいです)。

テストは、以下の点を判断するために必要です:

  1. ある文書定義を画像に適用した場合に、 十分な数の マークされたアンカーと識別子があるかどうか。
  2. フィールドプロパティ 正確に設定されています。
  3. ルール 正確に設定されています。
  4. エクスポートは 正確に設定されています。

テスト中、文書の処理時に実行される連続したアクション全体を、実行しなければなりません。

テスト中にルールエラーや不正確なフィールドなどが検出された場合、 文書定義を編集して 訂正しなければなりません。

検出された問題すべてを除いた後で初めて、文書定義を発行し、大量の文書インプットを始められます。

以下も参照してください:

設定されたプロジェクトの操作

1/14/2021 2:17:22 PM


Please leave your feedback about this article