Fenster des Skripteditors

Mit dem Skripteditor können Sie Skripte schreiben und bearbeiten.

Sie können eine gewünschte Skriptsprache für Ihr Skript auswählen: VBScript, JScript.Compact, JScript, C#.Net, VisualBasic.Net oвуr JScript.Net.

Die gewählte Sprache wird auch verwendet, wenn Sie den Editor das nächste Mal starten.

Überprüfen von Skripten

Es gibt mehrere Möglichkeiten, um das Debugging eines Skripts zu beginnen:

  • Drücken Sie F9
  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Überprüfen
  • Öffnen Sie das Menü Extras und klicken Sie auf Skript überprüfen.

Wurden keine Fehler festgestellt, wird die Nachricht Skript ist korrekt. angezeigt.

Enthält das Skript Fehler, erscheint im Fehlerfenster eine Liste der Fehler. Doppelklicken Sie auf eine Fehlermeldung im Fehlerbereich, um den Mauszeiger über der Stelle mit dem Fehler im Skripteditor zu positionieren.

Hinweis. Sie können fehlerhafte Skripte speichern und die Fehler später beheben.

Standardmäßig wird das Fenster mit den Fehlermeldungen unten im Editor angezeigt. Sie können die Größe dieses Fensters mit der Maus ändern. Sie können auch seine Position ändern (weitere Informationen finden Sie weiter unten).

Anpassen des Editors

Im Menü Ansicht können Sie das Erscheinungsbild des Editors anpassen. Das Menü Ansicht enthält die folgenden Elemente:

  • Fehlerfenster
    Verändert die Position des Fehlerfensters im Editor. Sie können es oben, unten (Standard), rechts oder links anordnen.
  • Symbolleiste
    Zeigt oder verbirgt die Symbolleiste.
  • Statusleiste
    Zeigt oder verbirgt die Statusleiste.

Hinzufügen einer benutzerdefinierten Funktion

Um eine benutzerdefinierte Funktion, hinzuzufügen, wählen Sie in der Dropdownliste der Symbolleiste eines der folgenden globalen Module: Script in <object_name\document_definition_name>, Regel für globales Skriptmodul, Globales Skriptmodul exportieren.

11/10/2020 12:08:03 PM


Please leave your feedback about this article