Script editor window

The script editor allows you to write and edit scripts.

You can select a desired scripting language for your script: VBScript, JScript.Compact, JScript, C#.Net, VisualBasic.Net or JScript.Net.

The selected language will remain selected the next time you start the editor.

Checking scripts

To begin debugging a script, you can:

  • Press F9
  • Click the Check button on the toolbar
  • Open the Tools menu and click Check Script.

If no errors were found, the Script is correct. message will be displayed.

If the script contained errors, a list of them will be displayed in the error pane. Double-click an error message in the error pane to place the cursor to the place with the error in the script editor.

Note: You can save scripts with errors and fix them later.

By default, the pane containing error messages is located at the bottom of the editor. You can change its size of this pane using the mouse. Also you can change its location (see below for details).

Customizing the editor

You can use the View menu to customize the appearance of the script editor. The View menu contains the following items:

  • Errors Window
    Changes the position of the error pane in the editor. You can choose to place it at the top, on the bottom (selected by default), on the right or on the left.
  • Toolbar
    Shows or hides the toolbar.
  • Status Bar
    Shows or hides the status bar.

Adding a custom function

To add a custom function, select one of the following global modules in the drop-down list on the toolbar: Script in <object_name\document_definition_name>, Rule Global Script Module, Export Global Script Module.

25.09.2020 9:24:45


Please leave your feedback about this article