Fenêtre Éditeur de scripts

L'Éditeur de scripts vous permet d'écrire et de modifier des scripts.

Vous pouvez sélectionner le langage souhaité pour votre script :  VBScript, JScript.Compact, JScript, C#.Net, VisualBasic.Net ou JScript.Net.

La langue sélectionnée restera sélectionnée la prochaine fois que vous démarrerez l'éditeur.

Vérifier les scripts

Pour commencer à déboguer un script, vous pouvez :

  • Appuyez sur F9
  • Cliquez sur le bouton Vérifier de la barre d'outils
  • Ouvrez le menu Outils et cliquez sur Vérifier le script.

Si aucune erreur n'est trouvée, le message Script correct. s'affiche.

Si le script contient des erreurs, une liste en contenant s'affiche dans le volet d'erreurs. Double-cliquez sur un message d'erreur dans le volet d'erreurs pour placer le curseur sur l'emplacement où se trouve l'erreur dans l'éditeur de scripts.

Remarque :Vous pouvez enregistrer des scripts avec des erreurs et les corriger ultérieurement.

Par défaut, la fenêtre Erreurs se situe en bas de l'écran. La taille de la fenêtre peut être ajustée à la souris. Vous pouvez également changer son emplacement (voir ci-dessous pour plus de détails).

Personnaliser l'éditeur

Vous pouvez utiliser le menu Affichage pour personnaliser l'apparence de l'éditeur de scripts. Le menu Affichage contient les éléments suivants

  • Fenêtre Erreurs
    Modifie la position du volet d'erreurs dans l'éditeur. Vous pouvez choisir de le placer en haut, en bas (par défaut), à droite ou à gauche.
  • Barre d'outils
    Affiche ou masque la barre d'outils
  • Barre d'état
    Affiche ou masque la barre d'état.

Ajouter une fonction personnalisée

Pour ajouter une fonction personnalisée, sélectionnez l'un des modules globaux suivants dans la liste déroulante sur la barre d'outils : le script dans <nom_objet\nom_définition_document>, Module de script global de règle, Module de script global d'exportation.

01.12.2020 7:04:01


Please leave your feedback about this article