Russian (Русский) - Change language

Настройка

Для настройки комплекса выполните следующие действия:

  1. Откройте Консоль Администрирования и Мониторинга под учётной записью пользователя с правами администратора Windows. Это можно сделать двумя способами:
  2. На странице Настройки → Сервер Приложений нажмите кнопку Создать новую базу данных и в открывшейся форме укажите следующие настройки:
Имя экземпляра сервера

(local)\sqlexpress

Замечание. Если SQL Server установлен не на локальной машине, имя экземпляра сервера будет иметь вид <computer_name>\sqlexpress

Имя базы данных FCDemoDataBase
Тип аутентификации пользователя Аутентификация Сервера Базы Данных
Имя пользователя и пароль Имя и пароль администратора Сервера Базы Данных, указанные при установке Microsoft SQL Server (см. раздел Установка)
Использовать внешнее файловое хранилище Отметьте опцию и укажите путь к файловому хранилищу, например, C:\FileStorage

Нажмите ОК. После создания базы данных вы являетесь её администратором с временным паролем password. Для дальнейшей работы в комплексе требуется перейти на страницу входа в систему (http://localhost/FlexiCapture12/Login) и сменить пароль.

Замечание. Подробнее о создании новой базы данных см. в разделе Создание базы данных.

  1. Настройте Сервер Обработки:
    1. Откройте Монитор Сервера Обработки (меню Пуск → Все программы → ABBYY FlexiCapture 12 Серверы → Сервер Обработки);
    2. В меню Действия выберите команду Добавить сервер  → Локальный хост.
    3. Убедитесь, что Сервер Обработки запущен (отмечен иконкой ), в противном случае выберите меню Действия → Запустить).
      Замечание. Подробнее о настройке Сервера Обработки см. в разделе Настройка Сервера обработки.
    4. Добавьте Станции Обработки, выбрав пункт Станции в дереве Серверы ABBYY FlexiCapture 12 → <Server_Name>, после чего в меню Действия выберите команду Добавить станции.... В открывшемся диалоговом окне нажмите кнопку По имени... и введите localhost, что добавит на Сервер Обработки локально установленную Станцию Обработки. Запустите Станцию Обработки (меню Действия → Запустить).
  2. Загрузите проект на сервер:
    1. Запустите Станцию Настройки Проектов (меню Пуск → Все программы → ABBYY FlexiCapture 12 Станции → Станция Настройки Проектов).
    2. Откройте локальный проект (меню Файл → Открыть проект...).
      Замечание. Вы можете выбрать проект из примеров, которые расположены в папке %public%\ABBYY\FlexiCapture\12.0\Samples.
    3. Загрузите проект на Сервер Приложений, используя команду Файл → Загрузить проект на сервер.... Адрес Сервера Приложений необходимо вводить в следующем формате: http://localhost.
      Замечание. В случае если Станция Настройки Проектов и Сервер Приложений расположены на разных машинах, адрес имеет следующий вид: http://<ApplicationServer>, где <ApplicationServer> - имя компьютера, на который установлен Сервер Приложений.
    4. Выберите опцию Использовать серверную идентификацию и введите имя администратора Сервера Баз Данных и пароль.
      Замечание. Если в проекте предполагается демонстрация импорта изображений из горячих папок, необходимо включить обработку горячих папок в Консоли Администрирования и Мониторинга (страница Настройки → Проекты).

Комплекс ABBYY FlexiCapture 12 готов для демонстрации.

Если вам необходимо более детально разобраться в настройках комплекса, а также в случае возникновения проблем при выполнении инструкций данного пункта, следует перейти к следующему разделу Развертывание комплекса в сети для промышленной обработки.

14.01.2021 14:17:24


Please leave your feedback about this article