Zapisywanie tabel

Program ABBYY FineReader umożliwia zapisywanie tabel w formatach XLS, XLSX oraz CSV.

XLS i XLSX

Aby zapisać tekst w formacie XLS lub XLSX:

  • Kliknij strzałkę znajdującą się obok przycisku Zapisz na głównym pasku narzędzi, a następnie kliknij polecenie Zapisz jako skoroszyt Microsoft Excelv lub Zapisz jako skoroszyt Microsoft Excel 97-2003…. Jeżeli potrzebnego formatu nie ma na liście, kliknij przycisk Zapisz w innych formatach…, po czym wybierz odpowiedni format z listy rozwijanej Zapisz jako typ. Można też w menu Plik kliknąć polecenie Zapisz dokument jako, a następnie wybrać opcję Skoroszyt programu Microsoft Excel 97-2003.

Podpowiedź: dodatkowe opcje zapisu są dostępne w oknie dialogowym Opcje: kliknij polecenie Narzędzia > Opcje…, przejdź do karty Zapisywanie, a następnie kliknij kartę XLSX.

Dostępne są następujące opcje:

Układ dokumentu

Wybierz jedną z opcji z tej listy rozwijanej, kierując się planowanym sposobem używania dokumentu:

  1. Tekst sformatowany

Zachowuje czcionki, rozmiary czcionek i akapity, ale nie zachowuje dokładnego położenia obiektów i odstępów między wierszami. Powstanie ciągły tekst wyrównany do lewej (teksty napisane w językach z pisownią od prawej będą wyrównane do prawej).

Uwaga: opcja ta spowoduje, że tekst pionowy zostanie napisany poziomo.

  1. Zwykły tekst

Nie zachowuje formatowania tekstu.

Ustawienia tekstu

  • Ignoruj tekst poza tabelami

Korzystając z tej opcji, można zapisać wyłącznie tabele i pominąć pozostałą zawartość dokumentu.

  • Konwertuj wartości numeryczne na typ liczbowy

Wybór tej opcji powoduje konwersję liczb na format „Liczby” w pliku XLS. Przy tym formacie program Microsoft Excel może wykonywać działania arytmetyczne w komórkach.

  • Zachowaj nagłówki i stopki

Wybór tej opcji pozwala na zachowanie nagłówków i stopek w dokumencie wynikowym.

  • Utwórz osobny arkusz dla każdej strony (tylko XSLX)

Wybierz tę opcję, aby zapisać każdą stronę z dokumentu źródłowego jako osobny arkusz.

Ustawienia grafiki

Można zapisywać grafiki w dokumentach XLSX. Dokumenty zawierające dużą liczbę obrazów mają duże rozmiary. Aby zmniejszyć rozmiar pliku, wybierz odpowiednią opcję z listy rozwijanej w grupie Ustawienia grafiki.

Podpowiedź:

  • Jeśli chcesz określić szerszy zakres parametrów jakości obrazu, wybierz opcję Niestandardowa… i zmień ustawienia w oknie dialogowym Ustawienia użytkownika.
  • Jeśli nie chcesz zachować grafik w rozpoznanym tekście, usuń zaznaczenie opcji Zachowaj obrazy (tylko XLSX).

CSV

Aby zapisać tekst w formacie CSV:

  • W menu Plik kliknij polecenie Zapisz dokument jako, a następnie wybierz opcję Dokument CSV. Można też kliknąć strzałkę znajdującą się obok przycisku Zapisz na głównym pasku narzędzi i wybrać polecenie Zapisz w formacie CSV. Jeżeli potrzebnego formatu nie ma na liście, kliknij polecenie Zapisz w innych formatach…, po czym wybierz odpowiedni format z listy rozwijanej Zapisz jako typ.

Podpowiedź: dodatkowe opcje zapisu są dostępne w oknie dialogowym Opcje: kliknij polecenie Narzędzia > Opcje…, przejdź do karty Zapisywanie, a następnie kliknij kartę CSV.

Opcje zapisu znajdujące się na tej karcie są podzielone na następujące kategorie:

Ustawienia tekstu

  • Ignoruj tekst poza tabelami

Korzystając z tej opcji, można zapisać wyłącznie tabele i pominąć pozostałą zawartość dokumentu.

  • Wstaw znak łamania strony (#12) jako separator strony

Wybór tej opcji powoduje zapisanie oryginalnego układu stron.

  • Separator pól

Korzystając z tej opcji, można wybrać znak, który będzie oddzielał kolumny danych w pliku CSV.

Kodowanie

Program ABBYY FineReader automatycznie wykrywa stronę kodową. Aby zmienić stronę kodową, wybierz odpowiednią stronę kodową z listy rozwijanej w obszarze Kodowanie.

1/14/2020 5:26:20 PM


Please leave your feedback about this article