Troubleshooting
After successful Timeline installation the timelinepi service is stuck in an endless cycle of restarts
Symptoms
- Timeline was installed successfully but the application is not working, and your machine seems to freeze. Also, CPU is loaded up to 100%.
- In Task Manager > Services, timelinepi service is stuck in an infinite cycle of changing Starting/Stopped statuses. At the same time, redis-wsl service has the Stopped status. If you try to start the redis-wsl service manually you get an error message.
- When opening \Users\<username>\AppData\Local\Temp\redis-wsl in the Redis.err file you can find an error message 'The file cannot be accessed by the system'.
Cause
This behavior can be caused by the WSL known issue: https://learn.microsoft.com/en-us/windows/wsl/store-release-notes#known-issues
Workaround
The steps below will help you to resolve the WSL issue:
- Manually stop the timelinepi service in Task Manager > Services.
- Open command line and execute the following:
wsl --update - In Task Manager > Services manually start redis-wsl and then timelinepi services.
Timeline installation failed on Redis step
This could happen if you have Redis preinstalled on your computer. It may cause conflicts while installing Timeline. Timeline distributes Redis within the installation process and expects to install Redis itself.
To solve the issue, run a new virtual machine without Redis and perform Timeline installation there.
9/5/2024 4:23:54 PM