Russian (Русский) - Change language

Обновление базы данных и проектов, созданных в предыдущих версиях программы

Данный раздел доступен пользователям с правами администратора ABBYY FlexiCapture.

Распределённая редакция ABBYY FlexiCapture работает с проектами, которые хранятся на Сервере Приложений в базе данных.  

Существует несколько различных способов перехода на ABBYY FlexiCapture 12 с предыдущей версии.

Подключение к базе данных ABBYY FlexiCapture предыдущей версии

После установки серверов ABBYY FlexiCapture 12, вы можете подключиться к базе данных и файловому хранилищу, которые использовали при работе в предыдущих версиях ABBYY FlexiCapture с помощью Консоли Администрирования и Мониторинга, после этого обновить базу данных до нужной версии и продолжить работу. В этом случае дальнейшая работа в ABBYY FlexiCapture предыдущей версии будет невозможна.

Замечание. Так как выполнение инструкций данного пункта приведёт к неработоспособности комплекса ABBYY FlexiCapture предыдущей версии, рекомендуем сделать резервную копию базы данных файлового хранилища перед выполнением данного пункта. Это позволит вам восстановить рабочую конфигурацию ABBYY FlexiCapture предыдущей версии в случае возникновения каких-либо проблем. Для этого сделайте резервную копию базы данных средствами MS SQL, Azure или Oracle, а также скопируйте всё содержимое файлового хранилища. Подробнее процедура резервного копирования описана в справке администратора соответствующей версии ABBYY FlexiCapture.

Для подключения к базе данных выполните следующие действия:

  1. Завершите работу с предыдущей версией ABBYY FlexiCapture:
    1. Завершите обработку всех пакетов, которые уже зарегистрированы в системе;
    2. Запустите Консоль Администрирования и Мониторинга;
    3. Рекомендуется выполнить очистку ненужных данных с помощью Консоли Администрирования и Мониторинга на странице Настройки → Очистка;
    4. Проверьте, что в комплексе нет открытых сессий. Для этого перейдите на страницу Мониторинг Системы → Сессии. Если активные сессии есть, то завершите работу клиентов, которые их открыли.
      Замечание. Если по каким-то причинам невозможно завершить работу всех клиентов и таким образом добиться отсутствия активных сессий, необходимо отключить Сервер Приложений ABBYY FlexiCapture от базы данных. Для этого необходимо очистить значение параметра HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\10.0 (или 11.0)\WebServices “DBConnectionString” в реестре и перезапустить службу World Wide Web Publishing Service в оснастке services.msc. Работа в комплексе ABBYY FlexiCapture предыдущей версии после этого будет невозможна.
  2. Подключитесь к базе ABBYY FlexiCapture предыдущей версии:
    1. Запустите Консоль Администрирования и Мониторинга ABBYY FlexiCapture 12, перейдите на страницу Настройки → Сервер Приложений и нажмите кнопку Подключиться к существующей базе данных;
    2. Укажите имя Сервера Баз Данных, имя базы данных и путь к файловому хранилищу, которые использовались в ABBYY FlexiCapture предыдущей версии и нажмите кнопку ОК. Подробнее о подключении к существующей базе данных см. в разделе Подключение к существующей базе данных;
  3. Обновите базу данных до версии ABBYY FlexiCapture 12:
    1. После подключения к базе данных ABBYY FlexiCapture предыдущей версии на странице Настройки → Сервер Приложений возле имени базы данных будет отображаться ссылка Обновить. Перейдите по данной ссылке. База данных будет обновлена до версии ABBYY FlexiCapture 12. После этой операции работа с этой базой данных из ABBYY FlexiCapture предыдущих версий будет невозможна.
  4. Обновите проекты на Сервере Приложений ABBYY FlexiCapture 12:
    1. Запустите Станцию Настройки Проектов ABBYY FlexiCapture 12 и откройте по очереди все проекты с Сервера Приложений ABBYY FlexiCapture. При открытии каждый проект будет обновлён до версии ABBYY FlexiCapture 12. Важно помнить, что обновлённый до FlexiCapture 12 проект невозможно будет открыть предыдущей версией программы. Обратите также внимание, что после обновления проекта определения документов находятся в состоянии «редактируется» и их необходимо опубликовать. Для этого выберите в меню Станции Настройки Проектов пункт Проект → Определения документов, далее выберите определения документов и нажмите кнопку Опубликовать.

Перенос проектов ABBYY FlexiCapture из предыдущей версии

Если Вы хотите сохранить установку ABBYY FlexiCapture предыдущей версии, но вместе с тем использовать ABBYY FlexiCapture 12 с теми же проектами, необходимо создать новую базу данных для работы ABBYY FlexiCapture 12 и перенести туда все проекты из базы данных, используемой предыдущей версией ABBYY FlexiCapture.

Внимание! При использовании данного способа не будут перенесены документы, находящиеся в комплексе.

Для этого выполните следующие действия:

  1. Выгрузите проекты с Сервера Приложений ABBYY FlexiCapture предыдущей версии в файловую систему:
    1. На Станции Настройки Проектов ABBYY FlexiCapture предыдущей версии откройте по очереди каждый проект с Сервера Приложений и с помощью команды главного меню Проект → Экспортировать проект выгрузите все проекты в файловую систему. При этом обрабатываемые документы выгружены не будут, поэтому необходимо завершить обработку документов в ABBYY FlexiCapture предыдущей версии.
  2. Создайте новую базу данных ABBYY FlexiCapture 12:
    1. C помощью Консоли Администрирования и Мониторинга ABBYY FlexiCapture 12 создайте новую базу данных и укажите путь к новому файловому хранилищу (см. раздел Создание базы данных).
  3. Обновите проекты до версии ABBYY FlexiCapture 12 и загрузите их на Сервер Приложений:
    1. На Станции Настройки Проектов ABBYY FlexiCapture 12 откройте по очереди все выгруженные в файловую систему проекты (*.fcproj). При открытии каждый проект будет обновлён до версии ABBYY FlexiCapture 12. Обратите внимание, что после обновления проекта определения документов находятся в состоянии редактирования и их необходимо опубликовать. Для этого выберите в меню Станции Настройки Проектов пункт Проект → Определения документов, далее выберите определения документов и нажмите кнопку Опубликовать;
    2. После обновления проекта загрузите его на Сервер Приложений с помощью пункта Файл → Загрузить проект на сервер главного меню Станции Настройки Проектов. Подробнее о загрузке проектов на сервер см. раздел Начало работы Руководства системного администратора .

09.10.2020 8:50:48


Please leave your feedback about this article