Russian (Русский) - Change language

Тестирование определений документов

Прежде чем приступать к массовому вводу документов, необходимо протестировать определения документов. Тестирование производится на документах, добавляемых в тестовые пакеты, т.к. эти пакеты работают с локальной версией определения. Эти пакеты доступны из меню Вид → Тестовые пакеты главного окна программы. Также к ним можно перейти из окна Редактора определения документа, выбрав пункт меню Пакет → Режим тестовых пакетов....

Внимание! С тестовыми пакетами может работать только пользователь, создавший их. При необходимости, роль постоянных тестовых пакетов могут играть рабочие пакеты, используемые как источник изображений для тестового пакета.

Тестировать определение документа можно прямо в Редакторе определения документа, на том изображении, которое используется для создания определения. Чтобы начать тестирование, выберите пункт меню Тестирование → Начать тестирование. Форма данных отобразится также, как и при обработке документов, будут показаны форматные ошибки, неуверенно распознанные символы и ошибки правил.

Для удобного расположения окон при тестировании воспользуйтесь меню Тестирование → Вид, а для навигации между объектами верификации, неуверенно распознанными символами и ошибками правил, меню Тестирование → Верификация. Для выхода из режима тестирования нажмите на кнопку Закончить тестирование документа или выберите пункт меню Тестирование → Завершить тестирование.

Внимание! В режиме тестирования перемещение разметки поля в окне изображения не приводит к перераспознаванию поля, как это происходит при работе в окне документа.

Для тестирования определения на других изображениях нужно выбрать тестовый пакет, перейти к нему можно из Редактора определения документа, выбрав пункт меню Пакет → Режим тестовых пакетов.... Перед вызовом диалога выбора тестового пакета происходит проверка правильности определения документа. В случае если ошибок нет, определение сохраняется и вызывается диалог выбора тестового пакета. При выборе какого-либо пакета происходит переключение на этот пакет в главном окне программы (главное окно становится активным).

Замечание. При необходимости документы можно копировать или перемещать между пакетами. При этом сохраняется вся информация о документе: наложенное определение документов, распознанные данные. Чтобы скопировать или переместить документы (например, из рабочего пакета в тестовый для отладки), выделите их в списке при просмотре содержимого пакета и нажмите сочетание клавиш Ctrl+C (для копирования) или Ctrl+X (для перемещения), кнопку или панели инструментов либо воспользуйтесь подпунктами Копировать или Вырезать пункта меню Правка. Далее откройте пакет, в который нужно скопировать или переместить документы и нажмите сочетание клавиш Ctrl+V, кнопку панели инструментов или выберите в главном меню пункт Правка → Вставить.

Рекомендуется проверить каждое определение не менее, чем на 20 изображениях документов (если документы заполняются от руки, то желательно, чтобы они были заполнены разными людьми).

Тестирование необходимо для того, чтобы выяснить:

  1. Достаточно ли выделенных реперов и идентификаторов для уверенного наложения определения документа на изображения.
  2. Корректно ли заданы свойства полей.
  3. Корректно ли заданы правила.
  4. Корректно ли настроен экспорт.

При тестировании должна быть проделана вся последовательность действий, выполняемая при обработке документов.

Если в результате тестирования были обнаружены ошибки в правилах, некорректно заданные значения свойств полей и т.д., то для их исправления необходимо отредактировать определение.

Только после устранения всех найденных проблем можно опубликовать определение документа и приступать к массовому вводу документов.

См. также:

Работа оператора с настроенным проектом

14.01.2021 14:17:24


Please leave your feedback about this article