Russian (Русский) - Change language

Разработка пользовательского отчета с использованием набора данных

Создание отчета MS Report в среде Microsoft Visual Studio

  1. В приложении Microsoft Visual Studio создайте новый проект типа Class Library:
    1. Выберите в главном меню пункт File → New Project.
    2. Выберите меню Templates → Visual C# → элемент Class Library.
  2. Добавьте в проект отчет MS Report:
    1. Выберите в главном меню пункт Project → Add New Item.
    2. Выберите меню Visual C# Items → Reporting → элемент Report.
  3. Выполните привязку отчета к набору данных (окно Report Data → New → команда Dataset...)
  4. Выберите созданный ранее набор данных и задайте ему имя RepDataSet.
    Внимание! Формирование отчета по данным из Консоли Администрирования и Мониторинга будет происходить только по этому имени.
  5. Разработайте дизайн отчета MS Report.
  6. Создайте XML-файл с описанием пользовательского отчета.
  7. Подключите пользовательский отчет, скопировав XML-файл описания и файл отчета MS Report (*.rdlc) в подпапку IIS. После подключения отчет будет доступен в подменю Пользовательские отчеты главного меню Консоли Администрирования и Мониторинга.

Создание отчета MS Report в среде MS Report Builder

  1. Запустите MS Report Builder и создайте источник Data Source (окно Report Data → контекстное меню Data Source → команда Add Data Source...).

    Подробнее

  1. Создайте набор данных (окно Report Data → контекстное меню Datasets → команда Add Dataset...) и задайте ему имя RepDataSet.
    Внимание! Формирование отчета по данным из Консоли Администрирования и Мониторинга будет происходить только по этому имени.

    Подробнее

  1. Откройте диалог свойств созданного набора данных (окно Report Data → контекстное меню RepDataSet → команда Dataset Properties).
  2. На вкладке Fields опишите поля набора данных и разработайте отчет MS Report.
  3. Создайте XML-файл с описанием пользовательского отчета.
  4. Подключите пользовательский отчет, скопировав XML-файл описания и файл отчета MS Report (*.rdl) в подпапку IIS. После подключения отчет будет доступен в подменю Пользовательские отчеты главного меню Консоли Администрирования и Мониторинга.

11/10/2020 12:08:08 PM


Please leave your feedback about this article