ABBYY FlexiCapture Cloud Developer’s Package

The ABBYY FlexiCapture Cloud Developer’s Package is a Standalone version of FlexiCapture designed for creating, modifying, and deleting Document Definitions, as well as using a GUI to set up local and server-side FlexiCapture projects.

It can also be used to test how documents are processed in existing projects, as well as uploading new projects to the server, updating existing projects on the server, and exporting scenarios from the server.

System requirements

CPU 2 GHz or faster
Operating system
  • Windows 7 SP1
  • Windows 8.1
  • Windows 10

Note: To use a localized version of ABBYY FlexiCapture, make sure your operating system supports the corresponding GUI language.

RAM at least 4 GB
Disk space 4 GB (including 2 GB for installation)
Other requirements* Note: Microsoft .NET Framework 4.5 or later
Windows 2012R2 already includes .Net Framework 4.5.1 but you will need to install ASP.NET 4.5. You can look up the version of your .Net Framework in the registry. Please visit this Microsoft web page for detailed instructions.

* Some workflows may also require Microsoft Office (version 2007 or later) or LibreOffice (version 4.0 or later), as well as a scanner with TWAIN, WIA or ISIS support.

 

Installing the ABBYY FlexiCapture Cloud Developer’s Package 

Important! Before installing the Developer’s Package, make sure that you have a Developer’s Package License. They are issued to FlexiCapture Cloud users through the Fulfillment team and activated using the License Manager.

To install the Developer’s Package, follow the steps below:

  1. Launch the setup wizard by clicking the setup.exe file located on the Downloads page: https://www.abbyy.com/flexicapture-downloads/cloud/.
  2. From the drop-down list, select the language that the wizard will use.
  3. Familiarize yourself with the EULA and click Next.
  4. Enter your username and organization name. Click Next.
  5. Specify the folder where the package will be installed and click Next.
  6. Click Install to begin the installation.
  7. Once the installation is complete, click Finish to close the wizard.

After you have successfully installed the Developer’s Package, you will be able to use the FCAdminTools application. For more information about FCAdminTools, see http://help.abbyy.com/en-us/flexicapture/12/admin_guide/projects_administration.

Scenario implementation 

Sample projects are included with the Developer’s Package installation.

The following scenario can be handled using the Developer’s Package:

  • Creating an invoice project. Open the File menu and select New Project.... From the Project type drop-down list, select either Invoice Processing (EU), Invoice Processing (US), Invoice Processing (CA) or Invoice Processing (Au-NZ) as the project type, depending on the location of the business unit (see Supported countries and languages). Next, specify a name for the project and the path to the folder in which it should be saved.
    Note: You can create several projects. For example, you can have a separate project for each department or for specific vendors.
  • Editing a Document Definition (e.g. enabling Line Items). Select Project → Document Definitions…, click Edit…, make any appropriate changes, and save them.
  • Uploading a project to the server. To upload your project to the Application Server, click File → Upload Project to Server... in the main menu. In the dialog box that opens, specify:
    • the URL of the server (i.e. https://<ApplicationServer> where <ApplicationServer> is the address of your ABBYY FlexiCapture Cloud Data Processing location, e.g. https://europe.flexicapture.com).
    • The Tenant name in the respective field.
    • The authentication type (Windows/server).
  • Creating a new batch and recognizing it locally. To create a new batch manually, right-click the batch list in the main window and select New Batch... from the shortcut menu. Add the appropriate documents to the batch and recognize them by right-clicking the batch and selecting Recognize from the drop-down menu.
  • Exporting a project. To export a project, select File → Export. Alternatively, you can use the Ctrl + U key combination.
  • Downloading a project. To open a project from the server, click File → Open Project from Server... in the main menu. In the dialog box that opens, specify:
    • the URL of the server (i.e. http://<ApplicationServer> where <ApplicationServer> is the address of your ABBYY FlexiCapture Cloud Data Processing location, e.g. https://europe.flexicapture.com).
    • The Tenant name in the respective field.
    • The authentication type (Windows/server).

Troubleshooting 

Should any problems arise, please consult the detailed functionality description in the Help Topics and User Guide supplied with ABBYY FlexiCapture. You may also browse the technical support section on our www.abbyy.com website, where you may find an answer to your question.

To provide expert advice, our technical support service requires the following information:

  • Last name, first name, patronymic
  • Organization name
  • Phone number (fax, e-mail address)
  • Serial number of your installation package
  • Build (see Help → About ABBYY FlexiCapture)
  • Note: To find out the current version of the web station and the server, click the ABBYY logo in the bottom right corner of the page.
  • General description of the problem with the full error message text (if available)
  • PC and processor type
  • Windows OS version
  • Other information you consider important

Address and contact details of ABBYY offices

09.10.2020 8:50:41


Please leave your feedback about this article