English (English) - Change language

Importing databases and projects from earlier versions of ABBYY FlexiCapture

This section is only available to users with System Administrator permissions.

The distributed edition of ABBYY FlexiCapture uses projects that are stored in a database on the Application Server.  

There are several ways to migrate to ABBYY FlexiCapture 12 from earlier versions of FlexiCapture.

Connecting to a database created in an earlier version of ABBYY FlexiCapture

After installing ABBYY FlexiCapture 12, you can use the Administration and Monitoring console to connect to a database and a file storage that were created in an earlier version of FlexiCapture. The database will be updated to make it compatible with FlexiCapture 12, and you will not be able to use it in earlier versions of FlexiCapture.

Note: Since the database will become unusable in earlier versions of FlexiCapture, you may want to make a backup copy. This will enable you to use the earlier version if you encounter any problems. To make the backup copy, create a backup in Microsoft SQL Server and copy all of the contents of the file store. For details on the backup procedure, see the System Administrator's help file in the earlier version of FlexiCapture.

Follow the instructions below to connect to a database created in an earlier version of FlexiCapture.

  1. Finish all processing tasks and close all sessions in the earlier version of ABBYY FlexiCapture:
    1. Finish processing all existing batches.
    2. Open the Administration and Monitoring Console.
    3. We recommend deleting all unnecessary data. To do this, click Settings → Cleanup.
    4. Close all sessions. To do this, click System Monitor → Sessions and close all clients that have active sessions.
      Note: If you cannot close all clients with active sessions, you will need to disconnect the Application Server from the database. To do this, open the registry editor and delete the value of the HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\10.0(or 11.0)\WebServices “DBConnectionString” and then restart the World Wide Web Publishing Service in the Microsoft Windows Services Console (services.msc). This will make the earlier version of ABBYY FlexiCapture unusable.
  2. Connect to the database of the earlier version of ABBYY FlexiCapture:
    1. Open the Administration and Monitoring Console of ABBYY FlexiCapture 12, click Settings → Application server and then click the Connect to Existing Database button.
    2. Specify the name of the database server, the name of the database, and the path to the file storage used by the earlier version of FlexiCapture. Click OK. For more on connecting to existing databases, see Connecting to an existing database.
  3. Update the database to make it compatible with ABBYY FlexiCapture 12.
    1. After you connect to the database, open the Administration and Monitoring Console of ABBYY FlexiCapture 12 and click Settings → Application server. Click the Update link next to the name of the database to update it. This will make the database incompatible with earlier versions of FlexiCapture.
  4. Update the projects on the Application Server of ABBYY FlexiCapture 12.
    1. Open the Project Setup Station of ABBYY FlexiCapture 12 and then open each project on the Application Server. When you open a project, it will be updated to make it compatible with ABBYY FlexiCapture 12. Bear in mind that updated projects will become incompatible with earlier versions of the program. Document Definitions in updated projects will receive the Edited status, so you will need to publish them in order to use them. To publish the Document Definitions, open the Project Setup Station, click Document Definitions on the Project menu, select the Document Definitions and click the Publish button.

Importing projects from earlier versions of ABBYY FlexiCapture

If you want to keep using the earlier version of ABBYY FlexiCapture and use projects from the earlier version in ABBYY FlexiCapture 12, you will need to create a new database for FlexiCapture 12 and import projects from the earlier version to this database.

Important! Existing documents will not be imported along with the projects.

Complete the following steps to import projects from an earlier version of FlexiCapture.

  1. Export projects from the Application Server of the earlier version of FlexiCapture to files.
    1. Open the Project Setup Station of the earlier version of FlexiCapture, open each project and export it by clicking Export Project... on the Project menu. If there are any documents left to process, make sure you process them before exporting the project, because they will not be exported along with the project.
  2. Create a new database in ABBYY FlexiCapture 12.
    1. Open the Administration and Monitoring Console of ABBYY FlexiCapture 12, create a new database and specify the path to a new file storage (see Creating a database for details).
  3. Update the projects so that they are compatible with ABBYY FlexiCapture 12 and upload them to the Application Server.
    1. Open the Project Setup Station of ABBYY FlexiCapture 12 and then open each project file (*.fcproj). When you open a project, it will be updated to make it compatible with ABBYY FlexiCapture 12. Bear in mind that updated projects will become incompatible with earlier versions of the program. Document Definitions in updated projects will become unpublished, so you will need to publish them in order to use them. To publish the Document Definitions, open the Project Setup Station, click Document Definitions on the Project menu, select the Document Definitions and click the Publish button.
    2. After updating a project, upload it to the Application Server by clicking Upload Project to Server on the File menu. For more on uploading projects to the Application Server, see the Creating and opening projects chapter of the System Administrator's Guide.

5/24/2018 7:39:29 AM


Please leave your feedback about this article